Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000479 [Lunar Linux] module minor have not tried 2011-04-27 13:20 2012-06-24 01:04
Reporter wdp View Status public  
Assigned To
Priority normal Resolution open  
Status closed   Product Version 1.6.5 Mare Ingenii
Summary 0000479: gtk+-2/gdk-pixbuf
Description gtk+-2 fails to compile with the following error, if not all dependencies at gdk-pixbuf for it are selected. I don't remember which dependency it was (png and jpg was there, i just added tiff, jasper
and the rest, and then it worked) So people will end up with a not working X11 / no gtk+-2 if they inproperly select gdk-pixbuf dependencies.

To solve above issue just lin -cr gdk-pixbuf select as many dependencies as you can ^^ and relin gtk+-2.
Additional Information libtool: link: ( cd ".libs" && rm -f "libprintbackend-lpr.la" && ln -s "../libprintbackend-lpr.la"
"libprintbackend-lpr.la" )
make[4]: Leaving directory `/usr/src/gtk+-2.22.1/modules/printbackends/lpr' make[4]: Entering directory `/usr/src/gtk+-2.22.1/modules/printbackends'
make [4]: Nothing to be done for `all-am'.
make[4]: Leaving directory `/usr/src/gtk+-2.22.1/modules/printbackends'
make[3]: Leaving directory `/usr/src/gtk+-2.22.1/modules/printbackends'
make[3]: Entering directory `/usr/src/gtk+-2.22.1/modules'
make[3]: Nothing to be done for `all-am'.
make[3]: Leaving directory `/usr/src/gtk+-2.22.1/modules'
make[2]: Leaving directory `/usr/src/gtk+-2.22.1/modules'
Making all in demos
make[2]: Entering directory `/usr/src/gtk+-2.22.1/demos'
/usr/bin/gdk-pixbuf-csource --raw --build-list \
        apple_red ./apple-red.png \
                gnome_foot ./gnome-foot.png \
        > test-inline-pixbufs.h \
|| (rm -f test-inline-pixbufs.h && false)
failed to load "./apple-red.png": Couldn't recognize the image file
format for file './apple-red.png' make[2]: *** [test-inline-pixbufs.h]
Error 1 make[2]: Leaving directory `/usr/src/gtk+-2.22.1/demos'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/src/gtk+-2.22.1'
make: *** [all] Error 2
Creating /var/log/lunar/compile/gtk+-2-22.1.bz2
! Problem detected during BUILD
Tags No tags attached.
lvu installed moonbase 20110425.13
Core Tools Theedge
lvu installed [lunar|theedge] 20110419
Attached Files

- Relationships

-  Notes
(0001152)
florin (developer)
2011-12-21 08:44

solved lomg time ago.

- Issue History
Date Modified Username Field Change
2011-04-27 13:20 wdp New Issue
2011-04-27 13:20 wdp lvu installed moonbase => 20110425.13
2011-04-27 13:20 wdp Core Tools => Theedge
2011-04-27 13:20 wdp lvu installed [lunar|theedge] => 20110419
2011-12-21 08:44 florin Note Added: 0001152
2011-12-21 08:44 florin Status new => resolved
2012-06-24 01:04 ratler Status resolved => closed


Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker