Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000485 [Lunar Linux] module major always 2011-05-27 01:19 2011-08-09 16:50
Reporter serial241 View Status public  
Assigned To
Priority normal Resolution fixed  
Status closed   Product Version 1.6.5 Mare Ingenii
Summary 0000485: webkit 1.2.7 fails to build
Description Error msg:

Can't locate Switch.pm in @INC (@INC contains: ./WebCore/bindings/scripts /usr/lib/perl5/site_perl/5.14.0/x86_64-linux-thread-multi /usr/lib/perl5/site_perl/5.14.0 /usr/lib/perl5/5.14.0/x86_64-linux-thread-multi /usr/lib/perl5/5.14.0 .) at WebCore/dom/make_names.pl line 38.
BEGIN failed--compilation aborted at WebCore/dom/make_names.pl line 38.
make: *** [DerivedSources/HTMLElementFactory.cpp] Error 2
Additional Information webkit seems to use the Switch perl module for configuring, which has been removed from the perl core distribution:
http://search.cpan.org/~jesse/perl-5.14.0-RC1/pod/perl5120delta.pod#Deprecated_Modules [^]

possible solution:
modulizing the seperate Switch and a webkit module depending on it. (Both attached)


A patch for webkit's make_names.pl would be better, though. But I can't provide that.
Tags No tags attached.
lvu installed moonbase 20110526.11
Core Tools Lunar
lvu installed [lunar|theedge] 20110419
Attached Files bz2 file icon Switch_webkit.tar.bz2 [^] (2,349 bytes) 2011-05-27 01:19

- Relationships

-  Notes
(0001132)
wdp (developer)
2011-08-09 14:49

Hey,

this is weird, i don't have this error and i'm not using that patch.
Whats your version of perl?
(0001139)
serial241 (reporter)
2011-08-09 16:45

As you might have seen in the error msg ;-) ...
it's 5.14.0

btw. iirc the patch has been merged into moonbase by now, which maybe the reason you're not having this problem.

So the ticket could be closed I think.
(0001140)
wdp (developer)
2011-08-09 16:50

as requested :)

- Issue History
Date Modified Username Field Change
2011-05-27 01:19 serial241 New Issue
2011-05-27 01:19 serial241 File Added: Switch_webkit.tar.bz2
2011-05-27 01:19 serial241 lvu installed moonbase => 20110526.11
2011-05-27 01:19 serial241 Core Tools => Lunar
2011-05-27 01:19 serial241 lvu installed [lunar|theedge] => 20110419
2011-08-09 14:49 wdp Note Added: 0001132
2011-08-09 14:49 wdp Status new => feedback
2011-08-09 16:45 serial241 Note Added: 0001139
2011-08-09 16:50 wdp Note Added: 0001140
2011-08-09 16:50 wdp Status feedback => closed
2011-08-09 16:50 wdp Resolution open => fixed


Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker